Slam does not automatically sync

Jul 18, 2010 at 11:07 PM

I have uninstall and reinstall slam. 1.3. it would not auto sync updates or new records to the db. I have to manually press sync button for to sync. tried creating new db, did not work. did this like 3 times. under diagnostic tab, it only shows sync record, when i update a record on the list, and the list shows the reocrd is updated, in the diagnostic panel of the slam control panel, it does not show that the table is updated or anything. nothing works.

Developer
Jul 18, 2010 at 11:21 PM

It is possible you meant to end your post with "I know this is open source software and I would sincerely appreciate some help solving this issue that I'm having."?

My guess is that the event handlers aren't attached.  Have you clicked "Activate" in the Slam control panel?

Allan

Jul 18, 2010 at 11:34 PM

oh - I didn't mean to come out slamming  SLAM. Sorry - If I did.  when I said nothing works, it means nothing that I have done works. not that this does not work. It is obvious that it does work for others here.

Yes, I have tried to activate and deactive several times.

Developer
Jul 18, 2010 at 11:51 PM

Try setting the slam logging to verbose.  Add the following to your web.config after the config sections:

<system.diagnostics>
<switches>
<add name="SLAMLogger" value="4" />
</switches>
</system.diagnostics>

Now, when you save an item, do you see an entry in the slam message table?

Also check your server's event log for an error. 

Jul 19, 2010 at 1:59 AM

Hi:

added to web.config

saved entry and did not see an entry in the slam message table.  when i manually press sync then entry is updated. 

 

Jul 19, 2010 at 4:27 AM

Hey,

I even tried to recreate a new list, and uninstall and reinstall the and create a new db. do you think it is something in our environment? it has the same symptoms. it updates, when we press sync.

this is strange. I don't understand what is going on.

THanks

Developer
Jul 19, 2010 at 10:25 AM
It looks like you posted to another forum as well. In that other one you indicate that you are maybe getting an error in the event log? If so, please paste the entire error. Are you using FBA or AD login? If the former, it might be that the account that the app pool is running under doesn't have read access to the slam config. Allan
Jul 19, 2010 at 12:41 PM

Hi:

I am using AD login.

System.NullReferenceException: Object reference not set to an instance of an object.
at AWS.SLAM.StructureMap.XmlTypeProfileSection.GetTypeProfileName(String siteCollection, String site, String id, String typeName)
at AWS.SLAM.StructureMap.ComponentFactory.GetInstance[T](String siteCollection, String site, String id, String typeName)
at AWS.SLAM.ComponentService.GetInstance[T](String siteCollection, String site, String id, String typeName)
at AWS.SLAM.ListItemEventManager.<>c__DisplayClass14.<ItemDeleting>b__10()
at Microsoft.SharePoint.SPSecurity.CodeToRunElevatedWrapper(Object state)
at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()
at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)
at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)
at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)
at AWS.SLAM.ListItemEventManager.ItemDeleting(SPItemEventProperties properties)

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

 

thanks,

Jul 20, 2010 at 4:00 PM

Yeah - this is strange. I saw that there are some people who recieved the same errors. Did you guys end up resolving it and getting slam to work?

I created a new list, new config.xml, new database, restarted after the uninstall. nothing worked at it. It still would not update the database if I change, insert, or delete a record on the list. I had to manually press sync for it to update. very strange. I am using 1.3. I even tried downgrading the version, but still did not do it. does anyone have any ideas?

Developer
Jul 21, 2010 at 3:02 AM

I think this is a symptom of a config issue, although I cannot tell what without checking your slam.config.  Can I see it?

Oct 13, 2010 at 9:29 PM
Edited Oct 13, 2010 at 9:31 PM

I ran into this same issue today and it turns out it was a config issue as brjenkins suggested.  Whenever I would add a record to the my slammed sharepoint list, I would notice the error message described above would appear in the windows application logs and the data wasn't appearing in the slam database.  I found this post after searching Google for the error message (this post was the first result) however I noticed there wasn't any resolution given.  I then found the post below which suggested adding the parameter SiteCollection="YourSiteCollection" to the <DataMapping> section of the slam.config file.  That fixed the automatic synching issue and errors no longer appeared in the windows application log after adding a record.. figured I'd post here just so others will know.

Link to other post: http://slam.codeplex.com/Thread/View.aspx?ThreadId=76747