Error compiling source code

Oct 11, 2011 at 6:29 PM

When I try to build the solution I am getting the following error:

The command "...createwsp.bat" exited with code 4

When I run the createwsp.bat from the command prompt I get the following output



C:\projects\Incubator\slam\slam-39673\AWS.SLAM\WSP>createwsp.bat Copying DLL ... ..\BIN\AWS.SLAM.Core.dll ..\BIN\AWS.SLAM.dll ..\BIN\AWS.SLAM.StructureMap.dll ..\BIN\Microsoft.SharePoint.Search.dll ..\BIN\StructureMap.dll 5 File(s) copied Copying Administration files ... ..\Administration\Activation.aspx ..\Administration\Configuration.aspx ..\Administration\Diagnostics.aspx ..\Administration\SLAMControlPanel.aspx ..\Administration\Synchronization.aspx 5 File(s) copied Building WSP ... WSPBuilder Version: 0.9.8.0408 Created by Carsten Keutmann GPL License 2007 Building the solution - please wait Could not load file or assembly 'Mono.Cecil, Version=0.6.8.8607, Culture=neutral, PublicKeyToken=eb8142a6d35291bc' or one of its dependencies. The syst em cannot find the file specified. Copying WSP file ... .\SLAM.wsp 1 File(s) copied

Any ideas?

thanks,

Luis

Developer
Oct 11, 2011 at 6:44 PM

Luis,

Did you get the source from the zip in the Downloads sections?

In any case, download this zip of the WSP Builder directory: http://slam.codeplex.com/releases/view/40756#DownloadId=291689

Replace the contents of the WSPBuilder folder with the contents of this zip.

Hope this helps,

Brian

Oct 11, 2011 at 9:43 PM

I was able to solve the issue by editing the createwsp. bat file. Since we also use wspbuilder I changed the path to the wspbuilder executable in the batch file to the one we normally use on our development machine and everything worked after that.

thanks,

Luis