Error while validating SLAM

Mar 26, 2009 at 8:55 AM

Hi,

Firstly, a fantastic product you have given to the community. Congratulations. The idea of linking up lists is great. I wonder how MS didnt think of that.

Now the issue, All installations are perfectly done. I edited the slam.config with my lists which are under a sub site called Projects. I am trying to link up the "Projects List" list and "Project Issues" list. After a few edits and clicking on the validate button reported zero errors/mismatches. All fields are perfectly matching. Now, I try to hit the back button, I get an unknown error. Also, When I go back to the site settings > SLAM Control Panel > Activation and click on the Activate button, I get the error again. HELP!! I cant wait to see the lists linked up.

Thanks,

Mahesh Iyer

P.S: I posted this on the Issue Tracker as well. For screenshots on the errors, please see http://slam.codeplex.com/WorkItem/View.aspx?WorkItemId=1463

Thanks

Mar 26, 2009 at 11:13 AM
Edited Mar 26, 2009 at 11:14 AM
Could it be because my site collection is under a sub folder from the root called sites/cpr. for eg: http://xxx.xxx.xxx.xx:9876/sites/cpr

So, when I click on the Activate button, the page that it's navigating to is http://xxx.xxx.xxx.xx:9876/_layouts/SLAM/Diagnostics.aspx. If you see, the folders are gone. So is this a programmatic issue? or am i doing something wrong?

Thanks,

Mahesh Iyer

Developer
Mar 26, 2009 at 5:40 PM
Mahesh,
Thanks for the feedback.  I noticed that when hitting Back on any of the pages when on the SLAM Control Panel under a site collection other than the root that you are redirected somewhere with respect to root.  It was coded with relative URLs with the intention that you remain in the correct site collection but that did not obviously work properly.  Please get the latest build, 1.1.7.  It will fix the redirection issues when in a non-root site collection.  With this fix I also tested activation on a non-root site collection and it seems to work.  Let us know if you still have an issue with it.

Thanks,
Brian
Aug 26, 2009 at 4:26 AM

Hello!  I have just downloaded, installed and config SLAM.  I am so close to pushing my sharepoint list data to my sql database I can smell it BUT I am getting the same error as Mahesh.  I am running version 1.2 so I think I have the fix with regards to the root site.  I have also tried everything referenced where the error was Error Unknown.  I am lost like Alice in Wonderland.  I know I am close though.  If anyone can help I'd be abso-freaking-lutely giddy!  Not too mention my butt would be out of a sling with the powers that be that are all over to get Crystal Reports talking to my Sharepoint List data.

Thanks!
Quanda

Developer
Aug 26, 2009 at 6:53 AM

In your SharePoint site's web.config change the CallStack attribute of "SafeMode" to "true", and set customErrors to Off.  Try to activate again and see if it is the error is helpful.

 

-Brian

Aug 26, 2009 at 2:33 PM

Brian-

Thank you I finally got a better error. See below...

Line 5: Incorrect syntax near 'max'.   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
   at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
   at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async)
   at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
   at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
   at System.Data.Linq.SqlClient.SqlProvider.Execute(Expression query, QueryInfo queryInfo, IObjectReaderFactory factory, Object[] parentArgs, Object[] userArgs, ICompiledSubQuery[] subQueries, Object lastResult)
   at System.Data.Linq.SqlClient.SqlProvider.ExecuteAll(Expression query, QueryInfo[] queryInfos, IObjectReaderFactory factory, Object[] userArguments, ICompiledSubQuery[] subQueries)
   at System.Data.Linq.SqlClient.SqlProvider.System.Data.Linq.Provider.IProvider.Execute(Expression query)
   at System.Data.Linq.DataContext.ExecuteMethodCall(Object instance, MethodInfo methodInfo, Object[] parameters)
   at System.Data.Linq.DataContext.ExecuteCommand(String command, Object[] parameters)
   at AWS.SLAM.Data.SqlLogDataRepository.CreateMessageTable(String tableSchema)
   at AWS.SLAM.Logging.SqlLogger..ctor(IConfigurationManager configuration)
   at AWSSLAMLoggingSqlLoggerInstanceBuilderaf11d2e48992419da5b85970dfe2678e.BuildInstance(IConfiguredInstance , BuildSession )
   at StructureMap.Pipeline.ConfiguredInstanceBase`1.StructureMap.Pipeline.IConfiguredInstance.Build(Type pluginType, BuildSession session, InstanceBuilder builder)

I remembered seeing someone else getting that 'max' error so I read through that and I am pretty sure the server I am using is SQL 2005 but I will double check.  Also here is my slam.config.  Am I missing anything?

<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
  <ConnectionStrings Default="SLAM">
    <add Name="SLAM" ConnectionString="Database=SLAM;Data Source=INTRANET;User Id=shrpnt;Password=UiCcU123" />
  </ConnectionStrings>

  <DataMapping DataSchema="SLAM">
    <List Site="RetailSales/Branches" Name="AE Sign In" ActivationOrder="1">
      <Fields>
        <Field Name="Status" SqlType="varchar(15)" SPType="Text" Required="true"></Field>
        <Field Name="Created By" SqlType="varchar(50)" SPType="Text" Required="true"></Field>
        <Field Name="FSR SignUp Timestamp" SqlType="DateTime" SPType="Date and Time" Required="true"></Field>
        <Field Name="First Name" SqlType="varchar(40)" SPType="Text" Required="true"></Field>
        <Field Name="Last Name" SqlType="varchar(40)" SPType="Text" Required="true"></Field>
        <Field Name="Contact Number" SqlType="varchar(12)" SPType="Text" Required="true"></Field>
        <Field Name="Appt?" SqlType="Boolean" SPType="Text" Required="true"></Field>
        <Field Name="Purpose of Visit" SqlType="varchar(50)" SPType="Text" Required="true"></Field>
        <Field Name="Branch" SqlType="varchar(25)" SPType="Text" Required="true"></Field>
        <Field Name="AE" SqlType="varchar(50)" SPType="Text" Required="true"></Field>
        <Field Name="AE PickUp Timestamp" SqlType="DateTime" SPType="Date and Time" Required="true"></Field>
        <Field Name="AE Complete Timestamp" SqlType="DateTime" SPType="Date and Time" Required="true"></Field>
      </Fields>
    </List>
  </DataMapping>
</Configuration>

Thanks again, your support is GREAT and so is the product...I just know it!

Quanda

Developer
Aug 26, 2009 at 2:46 PM

Hi Quanda,

Please confirm that you are using SQL2005.  I'm almost certain that's the issue. 

Let us know if that's not the issue.

Yours,

Allan

Aug 26, 2009 at 2:49 PM

Allan-

I just heard back from IT that server is using 2000 and unfortunately it is the only server I can use.  I am talking to them about upgrading.  Guess there is no workaround for 2000?  Thank you for the prompt reply.

Quanda

 

Developer
Aug 26, 2009 at 2:53 PM

Unfortunately there is currently no workaround for 2000.  And honestly there hasn't been much demand for it.  Feel free to add it as an Issue and see if other folks vote for us to support 2000.  But given that 2000 is already two revs old, not sure we're going to prioritize that update.

Yours,

Allan

Aug 26, 2009 at 3:02 PM

Allan-

No that's fine.  I will leave it at that as they really need to upgrade the server.  Thanks so much for all the support!

Quanda