aws.slam error in event log

Mar 28, 2014 at 1:08 AM
Hello,

My server continually generates event log errors like the one below:

Log Name: Application
Source: Microsoft-SharePoint Products-SharePoint Foundation
Date: 3/27/2014 9:29:23 AM
Event ID: 6875
Task Category: General
Level: Error
Keywords:
User: ********
Computer: ********
Description:
Error loading and running event receiver AWS.SLAM.ListItemEventManager in AWS.SLAM, Version=2.0.0.0, Culture=neutral, PublicKeyToken=28f8d30936a98765. Additional information is below.

: The source was not found, but some or all event logs could not be searched. Inaccessible logs: Security.

SLAM synchronization seems to be working OK, and the account (omitted above) is a member of Event Log Readers, so it should be able to read the security log. Is this a problem? How can I stop SLAM from generating these errors (even if it is not a problem, it does clutter up the application log).

Thanks!
Developer
Mar 28, 2014 at 1:17 AM
Have you registered the event source? There is a .reg file with the setup package.
Mar 28, 2014 at 1:27 AM
I believe so - I inherited this system and the install notes from a previous admin include the statement: Run .reg file. Is there a quick place I can check in the registy to confirm the right .reg file was run?
Developer
Mar 28, 2014 at 1:43 AM
The key that is added is in HKLM\SYSTEM\ControlSet001\Services\EventLog\Application\SLAM
Mar 31, 2014 at 6:00 PM
Thanks very much - I checked and that key is missing. Can I still add it? If so, can I download the .reg file from somewhere? I will look for the install source but I am not sure if we still have it...
Developer
Mar 31, 2014 at 9:08 PM
The reg file is in the most recent setup package.
Mar 31, 2014 at 9:40 PM
Thanks - I have downloaded it. Do I need to restart anything (SLAM, sharepoint timer, anything else) after applying the .reg file?
Developer
Mar 31, 2014 at 9:44 PM
I don't think so. If the error continues you may try recycling the app pool just to be sure that was actually not the issue.