This project is read-only.

Loading existing SharePoint List data

Sep 9, 2014 at 1:01 AM
Hi All,
I have hooked up the latest release of SLAM to a number of existing SharePoint lists which have data in them. From what I have read, it was my understanding that when I activated SLAM that the database structure would be created (which did happened) and that the existing list data would be put into the corresponding tables. This doesn't seem to have happened. When I put new data in the list, this data appears in the tables, but the existing data is not there. Here is my slam.config file if that helps.

<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
<ConnectionStrings Default="SLAM">
<add Name="SLAM" ConnectionString="Database=SLAM_Test;Server=DEVSVR04;Trusted_Connection=True;"/>
</ConnectionStrings>
<TypeIdDefinitions>
<!-- <add Name="Global" SqlType="varchar(25)" IsPrimaryKey="true" NameFormat="{TableName}ID" ValueFormat="Hex" ReplaceSharePointIds="true" /> -->
<add Name="GlobalWithSharePointIDs" SqlType="varchar(25)" IsPrimaryKey="true" NameFormat="{TableName}ID" ValueFormat="Hex" ReplaceSharePointIds="false" />
</TypeIdDefinitions>

<DataMapping DataSchema="SLAM" TypeIdDefinition="GlobalWithSharePointIDs" SynchronousUpdates="true">
<List Name="Clients" ActivationOrder="1">
  <Fields>
    <Field Name="ClientName" SqlType="varchar(255)" SPType="Text" Required="true"></Field>
  </Fields>
</List>
<List Name="Projects" ActivationOrder="2">
  <Fields>
    <Field Name="ProjectName" SqlType="varchar(255)" SPType="Text" Required="true"></Field>
    <Field Name="Client" Column="ClientsListItemID" SPType="Lookup" AssociatedTypeName="Clients" Required="true"></Field>
  </Fields>
</List>
<List Name="ProjectTasks" ActivationOrder="3"> 
  <Fields>
    <Field Name="ProjectTaskName" SqlType="varchar(255)" SPType="Text" Required="true"></Field>
    <Field Name="Project" Column="ProjectsListItemID" SPType="Lookup" AssociatedTypeName="Projects" Required="true"></Field>
    <Field Name="EstimatedTime" SqlType="decimal(18,2)" SPType="Number" Required="true"></Field>
    <Field Name="Notes" SqlType="varchar(max)" SPType="Text" Required="false"></Field>
  </Fields>
</List> 
</DataMapping>
</Configuration>

Thanks for any help in advance.
Theresa.
Developer
Sep 9, 2014 at 1:29 AM
You need to synchronize the data. SLAM keeps your data up to date in real time once it's configured. But you need to Synchronize it for the first time. There's an option in the SLAM configuration screens.

Allan
Sep 9, 2014 at 2:25 AM
When I try to Sync I am getting the error:
Invalid column name 'SlamIsSynched'. There is no column called that in the SLAM database.


Sep 10, 2014 at 12:13 AM
It seems that other people have run into the SlamISSynched problem before but I cannot see where this problem has actually been addressed.
Developer
Sep 10, 2014 at 1:29 AM
When synchronizing SLAM will add a SlamIsSynched column to the table it is currently syncing and a trigger. I would think there would be another error related to an inability of SLAM to add the column?