This project is read-only.

Requested registry access is not allowed

Jul 29, 2009 at 5:57 PM

Hello,

We just installed SLAM and everything works great except that when update our SharePoint list, the corresponding database table is NOT updated.  We have to manualy click the "Synchronize" button in order to propagate any data changes.   we are getting this error in our Application Event Log:

Error loading and running event receiver AWS.SLAM.ListItemEventManager in AWS.SLAM, Version=1.0.3.0, Culture=neutral, PublicKeyToken=28f8d30936a98765. Additional information is below.: Requested registry access is not allowed.

Event Type: Error
Event Source: Windows SharePoint Services 3
Event Category: General
Description:
Error loading and running event receiver AWS.SLAM.ListItemEventManager in AWS.SLAM, Version=1.0.3.0, Culture=neutral, PublicKeyToken=28f8d30936a98765. Additional information is below.
: Requested registry access is not allowed.

 

Have you seen this error before?

Thanks for your time,
Dave

 

 

Developer
Jul 29, 2009 at 6:06 PM

Hi Dave,

In the install package is a file called RegisterEventSource.reg.  Did you run that?  That allows SLAM to write to the registry.  It's not preventing SLAM from updating the tables but hopefully will allow you to see what the issue is.

Did you activate SLAM?  Did you check the diagnostic table in SQL to see if any errors are being raised there?

Allan

Jul 29, 2009 at 6:42 PM

Thanks Allan.  I missed that configuration step with the ".reg" file, so I just ran that and am now getting a different error when I add a new item to my SharePoint list, which is called "Owners".  This error is in the Application Event Log:

System.NullReferenceException: Object reference not set to an instance of an object.
   at AWS.SLAM.StructureMap.XmlTypeProfileSection.GetTypeProfileName(String siteCollection, String site, String id, String typeName)
   at AWS.SLAM.StructureMap.ComponentFactory.GetInstance[T](String siteCollection, String site, String id, String typeName)
   at AWS.SLAM.ComponentService.GetInstance[T](String siteCollection, String site, String id, String typeName)
   at AWS.SLAM.ListItemEventManager.<>c__DisplayClass4.<ItemAdded>b__0()
   at Microsoft.SharePoint.SPSecurity.CodeToRunElevatedWrapper(Object state)
   at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()
   at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)
   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)
   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)
   at AWS.SLAM.ListItemEventManager.ItemAdded(SPItemEventProperties properties)

Yes, I activated and synched SLAM just before adding this new item to my list. I checked the "SLAMEventLog" and "SLAMMessageLog" tables, but there are no errors in there.   If I go back into the SLAM Control Panel and "Synchronize SLAM", the new item appears in the database table.

Any ideas?

Thanks.

Dave

Developer
Jul 30, 2009 at 8:57 PM

And when you save any other items in you list individually it logs this error?

-Brian