Activating SLAM

Aug 22, 2009 at 8:58 AM

This might sound crazy considering the fact that nobody else has posted an issue regarding this so I assume I'm the only one having it.... 

The SLAM installation seems to complete just fine,  but I can't ever see it to activate it in Sharepoint Site Settings.  Can anyone help?  It's driving me absolutely nuts.  I've uninstalled, reinstalled, tried different installer versions, nothing works.

Developer
Aug 23, 2009 at 1:33 PM

Do you get any error messages at all?  Did you check the event log? (You need to make sure to register the event source so SLAM can write to the event log.)

After the install process if complete, if you go to: [your site]/_layouts/SLAM/SLAMControlPanel.aspx do you see the slam control panel?

Allan

Aug 24, 2009 at 3:25 PM

Thanks for your help.  I do see the SLAM control panel when I go directly to the URL you provided.  I was under the impression that I should have been able to see it just by going to my Site Settings, Site Administration section, and it would appear under Site Features.  According to the the setup tutorial given on this site http://slam.codeplex.com/Wiki/View.aspx?title=Getting%20Started, I believe that's where I was supposed to look. 

Anyways, it works now and that's all that matters.  Thanks again.

Jerry

Developer
Aug 24, 2009 at 3:38 PM

Hmmm.  This is first time anyone has reported that issue. 

Are you sure you are looking at the settings for the top site?  (Do you see a link on the right-most column saying "Go to top level site settings?")

Allan

Aug 24, 2009 at 4:06 PM

I do not see that link, so I'm fairly certain I am at the top level site.  However, interestingly enough, I also don't see that link when I go to the settings of my sub-site.  I know where I'm supposed to be looking because the link does exist in the settings of our production environment sub-sites.

Developer
Aug 24, 2009 at 4:09 PM

Can you send a screen shot of your site settings page?

Aug 24, 2009 at 4:47 PM

I've been wanting to send a screenshot since my first post, but I can't seem to paste any images in here, whether I try a snippet or print screen.

Developer
Aug 24, 2009 at 4:52 PM

Try this:  http://jingproject.com/  (it'll even allow you to narrate a screen cast and then post it as a link). 

Aug 24, 2009 at 5:16 PM

This is great! Thanks!

Ok, so this is a screenshot of what my Site Settings page looks like.

http://www.screencast.com/users/jmin28/folders/Jing/media/c0966fca-1788-4a2c-9486-36b4f122bb8c

And this is what it looks like when I go into Site Features under Site Administration.

http://www.screencast.com/users/jmin28/folders/Jing/media/2fbaae10-e97d-4a4d-aa00-8f406ba3f040

As I said before, I can see the SLAM control panel by going directly to the URL.

http://www.screencast.com/users/jmin28/folders/Jing/media/4438cfd9-e6a6-400b-ad01-4ccbe7bf06cd

Developer
Aug 24, 2009 at 5:18 PM

Are you logged in as the site collection administrator?  I suspect that's the issue.

Aug 24, 2009 at 5:28 PM

That was the issue.  I assumed I was a site collection admin because my colleague who set up Sharepoint on this development box said he made me one, but in fact I only had Full Control permissions.

Thanks again for all your help.

Jerry

Developer
Aug 24, 2009 at 5:36 PM

Sure thing.  Happy slamming!

Allan

Mar 2, 2010 at 7:25 AM

Well, I got the same problem here. But I am site collection administrator!

Screenshot of site settings:

http://www.screencast.com/users/Renator/folders/Jing/media/b3179bfb-164a-4f25-945e-cfd22b3bcdee

Site Feature:

http://www.screencast.com/users/Renator/folders/Jing/media/0fd51970-9538-4a35-8ed6-88a0bf26fd08

SLAM control panel:

http://www.screencast.com/users/Renator/folders/Jing/media/f8a0ed92-954b-42e4-8351-6dd368d2d397

Site collection administrator:

http://www.screencast.com/users/Renator/folders/Jing/media/970b29f7-597c-42d2-8e33-8df74cd34cc1

 

I'm sorry, its german, but looks the same way!

Dont know what to do. Is there any workaround or something?

 

Thanks so far!!!

Developer
Mar 2, 2010 at 6:55 PM

Renator,

SLAM is a site collection feature, not a site feature.  Once you activate the site collection feature you will see the SLAM Control Panel link appear under Site Collection Administration.  Even if you get to the SLAM Control Panel via the link the result will be the same as navigating directly.  As the error suggests, you need to create a slam.config in the root of your site's virtual directory.  Right now it cannot find a slam config.

-Brian

Mar 3, 2010 at 6:11 AM

Hi Brian,

well i've used the slam.dummy.config, renamed it to slam.config and put it to the root of the site's virtual directory. Is there no chance to test it with the dummy or is it a must to config it immediatly the right way?

I'm doing hard to config...

Developer
Mar 5, 2010 at 10:05 PM

Right, so you need to change the dummy config.  It only contains examples, so it won't be at all useful unless you created lists to match it.  And of course in any case you need to change the connection string.

Mar 18, 2010 at 8:42 AM

Hi Brian,

thank you so far. Found the time to try it again.

Well I could activate the site collection Feature and now the Link is there.

Also tried to config the slam.dummy.config, but dont know if I understand it the right way. If I use the validate Button it doesnt show any error, but if I use the Activate Button it just shows unknown error.

Well I think its just the wrong way I used slam.config...

Would you please show me in a short example how to connect 2 tables with n:n?

TableA got a field: VarChar1

TableB got the title which should be connected to TableA - VarChar1

 

Thanks!!!

Developer
Mar 18, 2010 at 11:13 AM

Can you send us your slam.confg?

Allan

Mar 18, 2010 at 4:20 PM

<?xml version="1.0" encoding="utf-8" ?>
<Configuration>
  <ConnectionStrings Default="SLAM">
    <add Name="SLAM" ConnectionString="Database=SLAM;Data Source=yyy;User Id=xxx;Password=xxx" />
  </ConnectionStrings>

  <DataMapping DataSchema="SLAM">
    <List Site="Side1" Name="TableA" ActivationOrder="1">
      <Fields>
        <Field Name="VarChar1" SqlType="varchar(255)" SPType="Text" Required="true"></Field>
        <Field Name="Title" SPType="Lookup" AssociatedList="TableB" AssociationName="ListToOtherList"></Field>
      </Fields>
    </List>
  </DataMapping>
</Configuration>

 

The Database is also made... just changed Source, User, Password and the Table names.