Integrated Authenitcation

Sep 25, 2009 at 9:30 PM

Has anyone got this working using integrated authentication?

I ran the Syncronize seems to have ran creates the tables and populates them.  However activating it it couldn't find the DB.

Also when you go to diagnositcs is has the message.

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

Here is my connection string

<add Name="Time" ConnectionString="Data Source=XXXXXX32\IT;Database=SPTimeLogReporting;Integrated Security=SSPI" />

The MOSS farm account that app pool is running as is the DB owner for the database I created.  That user also has dbcreator and securityadmin at the server.

It is SQL 2005.

Jul 27, 2010 at 4:30 PM

I too am running into this issue, did you ever get it resolved?  I have the appPool account as DBO on the DB and get the exact same message on the Diagnostics tab.  Any suggestions?

Thanks,
Kel

Jul 27, 2010 at 4:46 PM

I newer did get it working.  I just ended up using a domain user account.

Jul 27, 2010 at 4:52 PM

Thanks for the quick response, so you just left the uid/pwd in cleartext w/in the config file? 

Here's something odd I just noticed, if you ignore the Anonymous error and simply go an Synchronize SLAM from the Activation menu, it actually creates and populates the tables at the destination and then throws up the same error.  So it's able to make the connection and it actually does sync in real-time afterwards.  Still a little scary and wish I knew where this error was coming from or how to resolve it before pushing forward.  Not sure our sec admin will like the plain text pwd in the config...

SLAM is attempting to connect to the database using the Default connection string defined in the SLAM configuration file but is failing to connect. It is receiving the following error:

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.
 
 
Thanks for any additional info.
 
Kel