SLAM Synchronization issue with different locale than english

Nov 4, 2009 at 3:05 AM
We have a web site (still running under a secured test environment - not exposed to external world). We are extensively using the SLAM as the way functional requirements changed, it became mandatory to have relational association of data.
 
Following was the setup at glance:
1. MOSS 2007 running on Windows 2003 server.
2. MS-SQL 2008 as content database and SLAM database platform.
 
On local system these configuration was working fine and the data was getting synchronized. Please note that the local version of MOSS 2007 and MS-SQL were installed with the basic language and/or collation which is "English".
 
When we deployed the same on the client demo server, which has the default system language set to Dutch, things were for a toss. The MOSS 2007 installed on client domain is also a Dutch Version (and not English). The numeric fields across the site are not getting synced properly. This is because of the fact that in dutch the coma and dot within a number format gets interchanged as compared to English version. When we try to sync the data, it gives us the error as it does not consider comma as valid character in numeric field.
 
We are not able to figure out the problem here. We would appreciate a quick response as we have a very hardpressing deadline of 2 days.
Thanks.
Developer
Nov 4, 2009 at 3:10 AM

There is a known issue when the database and SharePoint servers are set to different localization settings.  As of yet there is not a workaround (other than setting the servers to the same localization setting).  This is on a list of bugs to correct but we don’t have a date yet for when we’ll get to it. 

Sorry I don't have better news.

Nov 4, 2009 at 7:04 AM

Awellenstein,

both the databases are running on the same SQL server instance and thus it seems to me that they must be having the same localization settings. Moreover, does the collation plays any role to it?

Nov 4, 2009 at 10:35 AM
Edited Nov 5, 2009 at 2:41 AM
Hi Awellenstein,
 
I just observed that in local environment when we do a simple insert of decimal value (say 10.25) and fire a select we get the same result.
 
But on client server when we insert the value 10.25 in same table and fire a select, we get 10,25 as result. Could it be that on the demo server the SQL server is installed in Dutch language and thus all results are coming in dutch format causing slam to fail and throw error?
 
Please let me know your views on the same at the earliest.
 
Regards.
Neeraj Singhal

On Wed, Nov 4, 2009 at 9:40 AM, awellenstein <notifications@codeplex.com> wrote:

From: awellenstein

There is a known issue when the database and SharePoint servers are set to different localization settings.  As of yet there is not a workaround (other than setting the servers to the same localization setting).  This is on a list of bugs to correct but we don’t have a date yet for when we’ll get to it. 

Sorry I don't have better news.

Read the full discussion online.

To add a post to this discussion, reply to this email (SLAM@discussions.codeplex.com)

To start a new discussion for this project, email SLAM@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

 

Developer
Nov 4, 2009 at 11:37 AM

Sorry for the delay in getting back to you.  Had to take care of some sleeping.

Are you only getting this error on synchronization?  Or do you get an error when you save a new item in sharepoint and it gets slammed?

Did you back-up and restore the sharepoint data to your client's server?

Please send us the actual error from the SLAM error log.

Allan

Nov 9, 2009 at 4:01 PM

Hi all,

I found the same error today with WSS 3.0 and SQL Server Express 2005 (both are in French localization), and I'm searching some informations about this.

First when I make test with numeric value I had to set WSS localization setting to English to avoid this error, but I finally found that when I perform a full synchronisation this error is still here.

The problem his that SQL Server need a '.' as decimal separator for insert/update and French localization setting set a ',' as decimal separator...

Could there is a way to avoid this kind of error?

 

Paul

 

 

Developer
Nov 9, 2009 at 5:44 PM

Hi Paul,

Yes, we also discovered the same when we looked into the error reported by Neeraj Singhal.  This issue will be correced in the next release of SLAM.

Thanks for your note!

Allan

Nov 10, 2009 at 2:52 AM

Hi Allan,

Thanks for the update. We would look forward towards the solution. We have found a solution for the above issue but this could be very case specific. We have used globalization in the SLAM source code which makes sure that all these number and datetime format conversions are done based on the locale set for.

Neeraj

Nov 10, 2009 at 6:47 AM

Hi Allan,

First thank you for your reply,...

Can you tell me approximatively when the next release of SLAM would be available?

Neeraj Singhal, you said that you have found a solution for this issue by using globalization can you tell me more about your solution?

Paul

Developer
Nov 10, 2009 at 1:26 PM

Hi Paul,

Before the end of the year likely but I honestly can't say for sure.  Depends on when we come up for air...

Allan

May 12, 2010 at 10:13 PM

Hi,

Is there a new release for thi issue already or a workaround?

All the best,

leopaiv@

 

 

 

Sep 13, 2010 at 7:53 AM

HI,

Working with SLAM I have the same troubles. MOSS 2007 En, SQL Server 2005 En but Win 2003 Server Fr...

Is there news about this issues ?

Thanks,

JB