This project is read-only.

The object has been updated by another user since it was last fetched

Feb 11, 2010 at 5:10 AM

I am getting this message repeatedly when I try to activate or deactivate SLAM.   I get no other events in diagnostics.  When I activate or deactivate, there is a very long pause, then nothing.  I am not taken to Diagnostics automatically.  I have to go there and I get the above error.  The slam.config validates fine.

Thanks!

Feb 11, 2010 at 2:03 PM
Edited Feb 12, 2010 at 2:59 PM

OK, I just enabled custom errors, and now I get this when I click Activate: 

The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
The object has been updated by another user since it was last fetched.
   at Microsoft.SharePoint.SPContentType.PushDownChanges(CodeToPushDownChangesToDerivedCT derivedCTPushdownCode, CodeToPushDownChangesToListCTs listDerivedCTsPushdownCode, Boolean throwOnSealedOrReadOnly)
   at Microsoft.SharePoint.SPContentType.UpdateOnWeb(Boolean bPushdown, Boolean bThrowOnSealedOrReadOnly)
   at Microsoft.SharePoint.SPContentType.Update(Boolean updateChildren, Boolean throwOnSealedOrReadOnly)
   at AWS.SLAM.SharePoint.SharePointServices.DetachAllEventHandlers(String assemblyName, String listClassName, String contentTypeClassName)
   at AWS.SLAM.Activation.Activator.Deactivate()
   at AWS.SLAM.Administration.Activation.btnAttachEvents_Click(Object sender, EventArgs e)
   at System.Web.UI.WebControls.Button.OnClick(EventArgs e)
   at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

No tables are created in the database, although events are logged in its log table.  No event handlers are added to any lists. 

Background on my environment:   I'm running Windows Server 2008 R2 x64, and MOSS is at v. 12.0.0.6520 (Oct 09 Cumulative Update).  

Also, I installed SLAM into this same site collection a few months ago, but then I uninstalled it until I could populate the data properly in the lists I"m trying to SLAM.  I did have to manually remove some of the event handlers.  In the interim, I had to move the content database to a new farm due to a disaster.  I reinstalled all the solutions the old farm had that I determined were still in use. Everything seems to be functioning normally.  I'm using least privileges configuration (separate accounts for services, app pools, etc). 

Does anyone know what this error means? 

Thanks! 

David