This project is read-only.

Exception error accessing Control Panel

Nov 22, 2009 at 4:17 AM

Just downloaded and installed the latest build - brand new install.  Config file is in place, but when I click on the SLAM Control Panel, I get the following error:

SLAM has encountered the following error:

System.TypeInitializationException: The type initializer for 'AWS.SLAM.ComponentService' threw an exception. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Xml.XmlException: 'Name' is an unexpected token. The expected token is '='. Line 18, position 44. at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args) at System.Xml.XmlTextReaderImpl.ThrowUnexpectedToken(String expectedToken1, String expectedToken2) at System.Xml.XmlTextReaderImpl.ParseAttributes() at System.Xml.XmlTextReaderImpl.ParseElement() at System.Xml.XmlTextReaderImpl.ParseElementContent() at System.Xml.XmlTextReaderImpl.Read() at System.Xml.Linq.XContainer.ReadContentFrom(XmlReader r) at System.Xml.Linq.XContainer.ReadContentFrom(XmlReader r, LoadOptions o) at System.Xml.Linq.XDocument.Load(XmlReader reader, LoadOptions options) at System.Xml.Linq.XDocument.Load(String uri, LoadOptions options) at System.Xml.Linq.XDocument.Load(String uri) at AWS.SLAM.Configuration.XmlConfigurationManager..ctor() at AWS.SLAM.StructureMap.SLAMRegistry.configure() at StructureMap.Configuration.DSL.Registry..ctor() at AWS.SLAM.StructureMap.ComponentFactory.Initialize() at AWS.SLAM.StructureMap.ComponentFactory..ctor() --- End of inner exception stack trace --- at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) at System.Activator.CreateInstance(Type type, Boolean nonPublic) at System.Activator.CreateInstance(Type type) at AWS.SLAM.ComponentService..cctor() --- End of inner exception stack trace --- at AWS.SLAM.ComponentService.ClearInstances() at AWS.SLAM.Administration.SLAMControlPanel.Page_Load(Object sender, EventArgs e)

I've been through the config file over and over, and I put in the dummy config (renamed, of course) just to see if that made a difference.  Same error, at same line and position, so I think it's something else.  Is there anything else I can try?


Nov 22, 2009 at 4:36 AM

Never mind - I restarted the app pool and that fixed it.  Apparently it doesn't refresh the config file.